Cisco роутер wifi 871, покрокове керівництво для чайника

Якщо у вас – новий роутер Cisco, навіть самий «простий» (наприклад, Cisco 851), налаштувати його «без консолі» спочатку – не можна. Тобто, вам знадобиться комп’ютер з СОМ-портом (або, якісним переходником), який ви підключаєте до роутера термінальним кабелем. Будь Cisco роутер, дозволяє «настройку» і по Telnet, і навіть через графічний інтерфейс, але все це – потім, вже після того, як ви підключіться до нього «терміналом».

Підключаємося по HyperTerminal

Термінальних програм (таких, як «HyperTerminal» в Windows) – існує велика кількість. При створенні підключення, потрібно вибрати правильний СОМ-порт:

вікно HyperTerminal

І потім, параметри з’єднання: 9600, 8, «ні», 1, “ні”. Це обов’язково:

Вікно налаштувань виклику

Ім’я користувача для входу на новий роутер: cisco (і пароль – той же).

Провід підключення cisco до комп’ютера

Про апаратне підключення, необхідно зауважити, що: термінальний кабель (роз’єм COM-порту – з боку, яка підключається до комп’ютера) – ви встановлюєте при вимкненому живленні роутера. На самому роутері, термінальний роз’єм – завжди один (з правого боку):

Звичайно, підключення кабелю повинно бути виконано до запуску термінальної програми.

Порт LAN і WAN

позначення портів

Роутер – повинен «отримувати» Інтернет з порту WAN, і роздавати його далі (в локальну мережу). У розглянутих моделях, використовується 5 інтерфейсів Ethernet, у тому числі останній (Eth4) – є портом «WAN».

Всі порти (від 0-го до 4-го), доступні за іменами (наприклад, «Eth0»). При цьому, порти «Eth0» – «Eth3» з’єднані з ще одним «портом» vlan1 через віртуальний «свіч» (комутатор).

Кілька важливих команд

Коли ви перебуваєте в консолі, включите роутер. На питання про запуск «майстри», дайте відповідь «n» ( «Enter»). Якщо запитають пароль – це cisco. Наберіть команду (натисніть «Enter»):

Переглянути наявні команд

Виклик довідки командою “?”

еnable

включення режиму з «підвищеним» доступом (після її застосування, значок «більше» – зміниться на «грати»);

conf t

режим зміни налаштувань, «конфігурації» (будь-яка команда – вносить зміни негайно);

username ім’я privilege 15 secret пароль

замість слів «ім’я» і «пароль», підставте що-небудь своє (то, що буде використовуватися);

вихід з «режиму зміни налаштувань» (замість цієї команди, можна натиснути клавішу «Контрол» і «Z»);

wr mem

зберегти зроблені зміни в постійну флеш-пам’ять роутера

Ще, є команда reload (перезавантаження). А також, erase (з атрибутом «startup-config», настройки – повністю скинуться до «заводським»).

Виконайте ці команди в зазначеному вище порядку. За замовчуванням, telnet-вимкнений, як і мережевий інтерфейс для графічної оболонки (SDM). Розглянемо, як настройка роутера cisco проводиться «в консолі».

Налаштовуємо циску через консоль

Налаштування DNS-серверів

Зайдіть в режим з підвищеним доступом (enable), потім – в режим «конфігурації» (conf t) “як розглянуто вище”.

Виконайте команду:

ip domain-lookup

без неї, доступ по іменах – неможливий.

Зауважимо, що DNS-сервер – може використовуватися внутрішній (вбудований в cisco)! За замовчуванням – він включений. А вимкнути, можна так: «no ip dns server».

далі:

ip name-server X.X.X.X

замість X, підставте адресу DNS-сервера, що надається провайдером.

На цьому, настройка роутера cisco на DNS – повністю виконана (що було не складно, чи не так?). Можна зберегти зміни (командою «wr mem»).

Налаштування локальної мережі

Ми повинні включити сервер DHCP, придумати локальну адресу IP для нього, і встановити діапазон адрес. Команди – необхідно набирати в режимі «конфігурації»:

interface Vlan1

перехід в режим настройки «порту» Vlan1;

ip address 192.168.D.1

присвоїли «порту» IP – адреса, на цьому ж адресу – потім буде web-інтерфейс (замість D – будь-яке число);

ip virtual-reassembly

включили збірку фрагментних пакетів;

Сервер DHCP – за замовчуванням включений (вимикають командою «no service dhcp»). пишемо:

ip dhcp excluded-address 192.168.D.1 192.168.D.99

нехай DHCP роздає адреси 100-255 (тут D – замінимо на те ж число);

ip dhcp pool LAN

пул адрес під ім’ям «LAN»;

network 192.168.D.0 255.255.255.0

вказали параметри мережі;

dns-server 192.168.D.1

в локальній мережі, сервер DNS – саме з цією адресою;

default-router 192.168.D.1

схоже, так треба :).

Потім, виконується «exit». В принципі, локальна мережа налаштована.

Включаємо графічний інтерфейс

Залишився останній штрих – дозволити управління через графічний інтерфейс. Якщо це не потрібно, даний блок – пропускаємо. Команди – будуть такі (в режимі «конфігурації»):

  • ip http server
  • ip http secure-server
  • ip http authentication local /// без цієї команди, в «web-інтерфейс» – не потрапимо
  • line vty 0 4
  • privilege level 15
  • login local
  • exit

Тепер можна виконати «wr mem» і «reload».

Встановимо графічний web-інтерфейс

Будь-cisco роутер, може одночасно «розуміти» команди з консолі, і з web-інтерфейсу.

Для цього, на комп’ютер встановлюється модуль Java ( «Jre», качати з java.com), і програма графічного інтерфейсу (називається «SDM»). Зверніть увагу: «SDM» можна встановити на сам роутер (а не тільки в ПК), про що – додатково «запитають» при установці.

Примітка: на браузері, повинен бути знята заборона спливаючих вікон. Якщо це IE – включіть також і «запуск активного вмісту»:

Налаштування браузера EXplorer

Підключіть патч-кордом мережеву карту ПК до роутера (до будь-якого порту від «3» до «0»). Мережева карта комп’ютера – повинна бути в режимі «автоматичних» DNS і IP. Обесточьте роутер при підключенні (дотримуйтесь вимог електробезпеки)!

Розглянемо, що виходить, якщо запустити «SDM» на виконання.

SDM Launcher

Замість встановленого (10.10 ..), потрібен IP-адреса, придуманий раніше (присвоєний «порту» Vlan1). Галочку «HTTPS» – краще зняти.

Тиснемо «Launch», далі – погоджуємося з сертифікацією. Бачимо вікно:

Входимо в Web-інтерфейс

Де – вводимо логін і пароль (ті, що придумали раніше, при виконанні «username»). Погодьтеся ще раз з прийняттям сертифіката:

приймаємо сертифікат

Через пару секунд, з’явиться «перша» вкладка – основне вікно «SDM»:

основне вікно SDM

Керівництво по інтерфейсу, знаходиться тут: www.cisco.com/en/US/docs/routers/access/cisco_router_and_security_device_manager/25/software/user/guide/SDM25UGD.html

Налаштування Інтернет підключення

Під «протокол DHCP», налаштувати – найпростіше:

  • Interface FastEthernet4 /// подайте цю команду в режимі «конфігурації» (налаштовуємо 4-й порт)
  • ip address dhcp /// сказали, що порт 4, отримує IP з зовнішнього DHCP;
  • ip virtual-reassembly /// включили збірку фрагментних пакетів;
  • duplex auto /// зрозуміло;
  • speed auto /// теж зрозуміло;

І, все – буде працювати. Не забувайте зберігати конфігурацію. Ще, можна додати «ip cef» (для прискореної комутації).

Файервол, за замовчуванням – НЕ задіюється. Якщо ви його включите – трафік стане рівним «0» (заборонено – все). Тому, потрібно виконати дозволяють команди для брандмауера, і тільки потім – його можна включити (тут – не розглядаємо).

Про налаштуваннях на VPN-протокол, можна прочитати тут (http://www.xakep.ru/magazine/xa/125/134/1.asp). В огляді, детально розглядають настройку «клієнта PPTP» (в «офіційної« документації – є тільки «L2TP»).

А якщо – PPPoE?

Тоді команди – були б наступними:

  • interface FastEthernet4 /// аналогічно;
  • no ip address /// «динамічний» адреса – призначається «DealerOne» -Інтерфейс;
  • duplex auto /// зрозуміло;
  • speed auto /// зрозуміло;
  • pppoe enable group global
  • pppoe-client dial-pool-number 1 /// вказали номер інтерфейсу (пулу);
  • exit /// порт – налаштований.

Робимо «DealerOne»-інтерфейс:

  • interface DialerOne
  • encapsulation ppp /// а що ж ще?
  • dialer pool 1 /// зв’язали «DialerOne» з порядковим номером пулу;
  • dialer group 1
  • ppp authentication chap callin
  • ppp chap hostname ім’я /// замінити «ім’я» на потрібне;
  • ppp chap password 7 пароль /// замінити (так само).

На цьому – все виконано (не забувайте «запам’ятовувати» все настройки). Додатково, в «DialerOne» – можна було додати:

  • mtu +1492 /// втім, він – “не 0» і за замовчуванням;
  • ip address negotiated /// для скидання і отримання IP при «перепідключенні»;
  • fair-queue /// алгоритм якийсь (стохастичний, ось!) – рекомендують для ADSL.

Ці настройки – для випадків, якщо модем – включений в режимі «моста». Успішного роутінга!

На закінчення – настройка Wi-Fi

Будь Cisco роутер wifi роздає не гірше за інших. Йдеться, в тому числі, про моделі «871W». Шкода тільки, що відсутній «швидкий» 802.11 n. Але дві антени, працюють, як і належить, в режимі «2х2» (тобто, пара каналів – одночасно).

Бажають розібратися з настройками в консолі – можуть дивитися тут (http://telecombook.ru/archive/network/cisco/wireless-network/79-cisco-871-wi-fi). Дуже хороший опис (якраз для цієї моделі), без будь-яких зайвих «теорій».

Правда, в разі web-інтерфейсу, без консолі повністю – не обійтися.

У режимі «конфігурації», потрібно виконати:

  • no service dhcp /// вимикаємо;
  • interface Vlan1
  • ip address 10.77.244.197 255.255.255.224
  • interface fastEthernet 0
  • switchport trunk encapsulation dot1q
  • switchport trunk allowed vlan add vlan1
  • exit /// «порт» – був налаштований.

Збережіть ці настройки (виконавши «wr mem»). Після чого, можна зайти в графічний web-інтерфейс. Мережеву карту ПК, потрібно налаштувати на IP: 10.77.244.1. Адреса web-інтерфейсу – тепер «10.77.244.197».

У графічному інтерфейсі, настройки виконують на вкладці «Configure»:

вкладка Configure

Зробіть вибір, як на малюнку ( «wireless»), натисніть «Launch Wireless App» (запустити «бездротове» додаток). Відкриється ще одне вікно браузера, де (до запуску мережі), можна налаштувати всі властивості:

Launch Wireless App

Як бачимо, мережа – виключена. Переходимо, перш за все, на останню вкладку ( «Сервіси»):

вкладка Сервіси

Тут, потрібно натиснути посилання «VLAN». І (в який з’явився) – «Routing»:

сервіс Vlan

Налаштовуємо, як на рис. нижче:

сервіс Vlan

Тобто, «мережу» буде: 10.1.1.1/16. Тільки, не намагайтеся задати SSID. Переходимо до закладки «Security» -> «SSID Менеджер»:

вкладка Security

Де – виконують настройки мережі (в тому числі, імені). По завершенні, натисніть «Apply». Бездротова мережа – почне функціонувати. Але зараз, Cisco роутер wifi-мережу – роздає «без захисту».

Можна включити шифрування (в закладці «Encryption Менеджер»):

Вкладка Encryption Менеджер

Допускається також «фільтрація MAC» (не будемо розглядати). Головне, налаштувати DHCP (так, щоб адреси мережі WLAN і VLAN – не перетиналися, і були «в одній» мережі). На вкладці «Configure», ви вибираєте (в лівій колонці): «Additional Tasks».

Налаштовуємо DHCP for cisco

Розкривши список «DHCP», перш за все, видаліть вже існуючі (кнопка “Delete”). Створіть новий сервер «DHCP» (кнопкою «Add»), і налаштуйте, як на малюнку:

Додаємо DHCP for cisco

Натисніть «ОК».

  • Складно налаштовувати?
  • Чи не є обов’язковими DNS всередині роутера і ідеальна швидкість роботи?

Тоді можливо, роутер Cisco Linksys (що-небудь з «верхніх» моделей) – стане хорошою альтернативою.

Ссылка на основную публикацию