Xposed Framework, сумісний з ART і Android 5.0 Lolipop випущений

Операційна система Android хороша тим, що більш-менш просунутий її користувач може в досить широких межах змінювати як її зовнішній вигляд, так і функціональні можливості за допомогою сторонніх додатків (клавіатури, лончер і т.п.) або альтернативних (кастомних) прошивок, таки як CyanogenMod або Paranoid Android.

Кром того, для додавання в систему нових функцій і можливостей, без необхідності перепрошивки свого смартфона або планшета, ви можете скористатися таким потужним інструменту, як Xposed Framework, створеним незалежним розробником rovo89.

Сам по собі Xposed не може нічого змінити в зовнішньому вигляді вашої системи або додати їй нові можливості – все це робиться шляхом установки на смартфон або планшет спеціальних модулів, які, власне, і роблять всю цю «магію».

На жаль, до сих пір Xposed Framework ні сумісний з найсвіжішою на сьогоднішній момент версією операційної системи Google: Android 5.0, а точніше – з новим середовищем виконання додатків ART, яка в ній використовується.

Це було причиною безлічі прикростей тих, хто раніше активно і з успіхом використовував фреймворк на своєму пристрої, а після поновлення його до Android Lolipop з подивом виявив, що Xposed перестав у нього працювати. Також, подібний стан справ не влаштовував і тих, хто хотів би на своєму смартфоні або планшеті з операційною системою Android KitKat на борту хотів би використовувати замість Dalvik середу виконання ART.

Минулого тижня для цієї категорії власників Android пристроїв ми повідомляли, що за кілька днів має з’явитися збірка Xposed Framework, сумісного з ART і Android 5.0 Lollipop. І ось це, нарешті, здійснилося!

Вже сьогодні ви можете скачати і встановити ранню збірку Xposed Framework, яка в даний момент має підтримку тільки ARMv7 процесорів. Це означає, що поки власники Android планшетів і смартфонів з 64-розрядними (ARMv8) процесорами не можуть нею скористатися. Але незабаром, розробник обіцяє виправити і це.

Також, розробник повідомляє, що нова збірка Xposed має деякі проблеми з сумісністю з заводськими прошивками на Samsung пристроях і про те, що процедура установки Xposed в Android 5.0 змінилася, в порівнянні з процедурою, описаною в цьому матеріалі.

Тепер, для того щоб встановити Xposed Framework на пристрій з Android 5 на борту, вам спочатку потрібно буде завантажити zip файл з фреймворком і модифікованою версією ART і встановити його на свій планшет або смартфон за допомогою або рекавери. Тільки після цього, як і раніше ви можете встановити APK файл Xposed Installer.

Майте на увазі, що в даний момент Xposed для Android 5 Lolipop знаходиться на етапі альфа тестування. Це означає, що він поки що має ряд недоробок і багато популярних модулі, такі як Greenify, Xprivacy або Amplify з ним не працюють, а такий мегапопулярний модуль як GravityBox працює з деякими обмеженнями.

Завантажити Xposed для Android 5 Lolipop ви можете в форуму XDA-Developers.

Ссылка на основную публикацию